Can't Init SimConnect - error code 0x80004005 - Solution

Ray Proudfoot
Posts: 105
Joined: Thu May 18, 2017 8:19 am

Can't Init SimConnect - error code 0x80004005 - Solution

Postby Ray Proudfoot » Sun Nov 17, 2019 5:57 pm

This may be helpful to anyone having SimConnect problems and specifically the message "Can't Init SimConnect - error code 0x80004005" which appears during the initial load.

I am running P3D v3.4 purely for a 32-bit FS Labs Concorde but it was fine a month ago. I spent nearly two hours uninstalling and reinstalling SimConnect, Visual C++ 2005 files and FSL Concorde but nothing worked.

So I tried launching v4 and that was fine. It was something in my P3D v3 setup. I searched for SimConnect.xml and discovered I had one in my v4 setup. But for some unknown reason there wasn't one in my v3 setup.

I copied simconnect.xml to %APPDATA%\Lockheed Martin\Prepar3D v3 and it solved the problem.
Ray (Cheshire, England).

System: P3D v4.5, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, Intel i7-8086K o/c to 4.6GHz, 32Gb G.Skill DDR4 3000Mhz RAM, Nvidia GTX 1080 Ti 11Gb, Win 10 Pro 64-bit, BenQ 32” UHD monitor.

Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 6 guests